Home/Support/Support Forum/Either cannot find device or firmware - XTCU.
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

Either cannot find device or firmware - XTCU.

0 votes
I have the following setup:

- Arduino expansion board (has Arduino Leonardo Chip) = https://www.dfrobot.com/product-1148.html
- Grove Base Shield = https://www.seeedstudio.com/Base-Shield-V2.html
- Grove Bee Socket = https://wiki.seeedstudio.com/Grove-Bee_Socket/
- Digi XBee 3 PRO (or normal one), 2.4 Ghz Zigbee 3.0, PCB Ant, TH MT - I do not know if mine is pro or not. The numbers on it are 1948(at the top), 94V-0(at below of it). I cannot look the other side of the chip, because it is integrated with Grove Bee Socket.

Xbee is connected to the Serial Port of the base shield.

I downloaded the XCTU, but it was not able to discover any module. Only once it discovered a module but then could not find any firmware. Then when I rerun the discovery, I got nothing. Both tried it on Windows and Linux.

What should I do to debug? Is my setup alright to program this module?
asked Dec 30, 2020 in XBee3 ZigBee by hkayan New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
These boards are not designed to connect the XBee to a PC. They are only designed to connect an XBee to an Arduino. You will need something like the XBIB-U-DEV board to connect the XBee to the PC.
answered Dec 30, 2020 by mvut Veteran of the Digi Community (15,515 points)
So there is no way to upgrade its firmware via those boards but I can program it without upgrading the firmware via Arduino?
That is correct.
Thank you. Last two questions then:

1 - When I send "+++" to Zigbee I get "OK" which means it is AT command mode. However it stays for a very short time there? How can I permanently set it in AT mode, because that is my only option with this setup?
That is correct. It will only remain in command mode till the Command Mode Timeout is reached of inactivity or the CN command is issued.

No, there is no way to Always be in AT command mode.  The radio is not intended to be always in command mode. It is intended to be in a transparent or API mode being able to send or receive data.