Home/Support/Support Forum/I can't update the Xbee PRO900HP firmware
New and improved user forum site coming soon
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

I can't update the Xbee PRO900HP firmware

0 votes
I have not been able to get the XCTU to recognize two XbeePRO 900 HP digimesh RF modules. The modules are mounted on a USB adapter.
I have tried to use the XBee recovery tool without success. I have tried with firmware versions 8462 and 8062
After finishing the automatic reset, a message appears asking me to manually reset the module, but neither the adapter nor the module has a reset button.
When I exit this screen, a window is displayed with a message
"error updating the radio firmware"
there is not an active bootloader in the module
Can anyone please recommend what to do?
asked Jan 11, 2021 in ConnectWare Manager by Hugo New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Sounds like you are not connecting all of the lines needed to perform the update with. Try using a board such as the XBIB-U or XBIB-U-DEV
answered Jan 11, 2021 by mvut Veteran of the Digi Community (15,515 points)
0 votes
But I don't have these accessories, I would have to import them since they don't exist in the local market of my country ( Ecuador).
At this moment I only need to make some simple tests with the modules, if they do not work I would not use them and I would have to look for another solution.
Is there no other way to try to reset them or update the firmware?
answered Jan 12, 2021 by Hugo New to the Community (1 point)