Home/Support/Support Forum/XBEE communication
New and improved user forum site going live on 12/6 (All users will need to reset their password when the new forum is active)

XBEE communication

0 votes
HI,
I am trying to communicate with two xbee series 2 module using X-CTU software.
I need the commands to communicate with xbee module so that i can transfer data from one pc to another pc.
It's urgent please help me out.
asked Jul 30, 2009 in ZigBee PRO Featureset (and legacy ZNet 2.5) by aruna New to the Community (12 points)

Please log in or register to answer this question.

26 Answers

0 votes
Hello Aruna,
to communicate between two Xbee module you have to configure their Destination address DL & DH using the AT command.
First let me know type of the module you are using whether Coordinator, Router or End device.
if you are using one coordinator and one router then using following command using the Hyper terminal for both devices:
Coordinator Side:
+++ / enter Command mode
ATCT 28F / set Command Mode timeout
ATID 1800 / set id to 1800 or any 4 digit number
ATWR / save setting
ATDH XXXX / set Source address High of router
ATDL XXXX / set source address Low of router
ATWR / save setting
ATCN / comeout from Command mode

Router side:
+++ / enter Command mode
ATCT 28F / set Command Mode timeout
ATID 1800 / set id to 1800 or any 4 digit number
ATWR / save setting
ATDH 0 / set Source address High of router
ATDL 0 / set source address Low of router
ATWR / save setting
ATCN / comeout from Command mode

Now check the communication between two devices. if still there is any problem write me again.
answered Jul 30, 2009 by rinkoo161 New to the Community (8 points)
0 votes
Thank You very much for ur reply.
I am very much knew to this xbee module.How can i know that my xbee module is coordinator,Router or End device.
answered Jul 31, 2009 by aruna New to the Community (12 points)
0 votes
download X-CTU application:
http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=2125


Attach your module to serial port, on X-CTU window click on PC setting TAB, and test your module; then go to modem configuration and click on READ button, on function set it will show you the type of module and also show you the rest of the setting of module.
answered Jul 31, 2009 by rinkoo161 New to the Community (8 points)
0 votes
i have followed the steps as suggested by you.
In X-CTU at modem configuration -> at modem: XBEE i got XB24-B and at Function set -> ZNET 2.5 ROUTER/ENDDEVICE AT
For both the devices i got the same configuration settings. Then how can i communicate with same XBEE devices. Please send me the commands.

Thanks in advance.
answered Jul 31, 2009 by aruna New to the Community (12 points)
0 votes
ok.

Means both devices are Router, now use the below mention step for both routers:

Connect both devices to hyper link and follow steps:

Router 1:
+++ / enter Command mode
ATCT 28F / set Command Mode timeout
ATID 1800 / set id to 1800 or any 4 digit number
ATWR / save setting
ATDH **** / set Source address High of router 2
ATDL **** / set source address Low of router 2
ATWR / save setting
ATCN / comeout from Command mode

Router 2:

+++ / enter Command mode
ATCT 28F / set Command Mode timeout
ATID 1800 / set id to 1800 or any 4 digit number
ATWR / save setting
ATDH **** / set Source address High of router 1
ATDL **** / set source address Low of router 1
ATWR / save setting
ATCN / comeout from Command mode

to get source address of Router use steps:

+++
ATSL
ATSH
atcn

or you can check it in X-CTU.
answered Jul 31, 2009 by rinkoo161 New to the Community (8 points)
0 votes
Thank You for ur reply.
I am connected my xbee module to my pc through rs232.In X-CTU software ->pc settings i was tested my modem it's shown as XB24-B after some time again i'm connected same module to my pc again i want to test a modem but it's showing some unknow name ID and also i dint get firmware version.I am enter into command mode after that i gave ATCT 28F but i dint get any system response.
answered Jul 31, 2009 by aruna New to the Community (12 points)
0 votes
Can you please send me some snapshot of what you have done on hyperlink?
answered Aug 1, 2009 by rinkoo161 New to the Community (8 points)
0 votes
I am connected xbee module to my PC through RS232.In X-CTU software -> PC settings tab i was tested my module but its showing as some unknown ID and i dint get the firmware version,what should i do now?please help me out
answered Aug 7, 2009 by aruna New to the Community (12 points)
0 votes
Hi Aruna,

Are you using the xbee znet series 2? Then you can configure them with the firmware XBP24-B (for xbee pro) or XB24-B (for xbee). For a network point-to-point simply configure a node as a coordinator and another as the end point through xctu.
answered Aug 7, 2009 by Jerry_Lee New to the Community (2 points)
0 votes
Hi

I am attaching my xbee screen shots. This zip file contains two snap shots.
1. when i am doing PC settings -> test/query i am getting this error.
2. At terminal tab i am not getting any response for the commands but i am entering in to the command mode.

Please make a glance and let me know.
answered Aug 8, 2009 by aruna New to the Community (12 points)
...