Home/Support/Support Forum/XBee3 Wireless GPIO with Micro Development Board

XBee3 Wireless GPIO with Micro Development Board

0 votes
I'm having some difficulty with a very basic GPIO problem using the XBee3 802.15.4 and the XBee Micro Development Board (xbib-c-mmt). I've been able to establish a network and send ASCII characters between my two modules. I am unable to turn on an LED from one board by triggering a GPIO on a second board.

My setup:
Device 1:
NI: Sender
PANID: 3001
CE: End Device
MY: 1
DH: 0
DL: 2
AP: Transparent Mode
D0: Digital Input [3]
IR: 14 (20ms)
IC (Digital I/O Change Detection): 1
IU: Enabled

NI: Receiver
PANID: 3001
CE: End Device
MY: 2
DH: 0
DL: 1
AP: Transparent Mode
P0: Digital Out, Low [4]. DIO10 is connected to a LED on the development board. If I set this to Digital Out, High [5] the LED will turn on. I want to turn the LED on from board 1.
IA: 1
IU: Enabled

It doesn't make sense to me that I can pass ASCII characters between the chips but not I/O messages. I have tried doing DIO10 to DIO10 and that still doesn't work. Am I missing something obvious? Is it possible to have DIO0 trigger DIO10?

asked Mar 11, 2021 in XBee3 802.15.4 by grmcwill New to the Community (0 points)

Please log in or register to answer this question.

1 Answer

0 votes
Try setting IA to FFFF
answered Mar 11, 2021 by mvut Veteran of the Digi Community (15,410 points)
No luck with FFFF. I think everything is connected correctly but I can't get the diode to turn on.
I just noticed that you listed P0 as your output pin. That really need to be D0 on the output side instead of P0.
Is it possible to have D0 on one board control P0 of another board or does it have to be a 1 to 1? D0 only controls D0?
It needs to be one to one. IE D0 to D0.
Thanks to your help I was able to get DIO4 to change states based on a button input. I found a slightly concerning issue regarding the output. If I set DIO4 to Digital output, low [4] or Digital output, high [5] the output of the pin is 3.3V. When I push the button on the sender circuit it the output goes from 3.3V to 0V.

Any idea why I can't get it to go from 0v to 3.3v?
Set the output to default out low.