Home/Support/Support Forum/No virtual method getADCChips()
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

No virtual method getADCChips()

–1 vote

I've been using the Android samples to evaluate this board; cc6imx6sbc. Android 8.0 from:

Tried running the ADC sample from: https://github.com/digi-embedded but getting this run time exception...

...E/AndroidRuntime: FATAL EXCEPTION: main
Process: com.digi.android.sample.adc, PID: 1623
java.lang.NoSuchMethodError: No virtual method getADCChips()Ljava/util/List; in class Lcom/digi/android/adc/ADCManager; or its super classes (declaration of 'com.digi.android.adc.ADCManager' appears in /system/framework/com.digi.android.jar)
at com.digi.android.sample.adc.ADCSampleApp.onCreate(ADCSampleApp.java:144)
at android.app.Activity.performCreate(Activity.java:6975)

It builds fine, starts, but then crashes so, I'm guessing I'm missing something from the SDK or the image.

Has anyone run into this exception? I'm using Android Studio 4.1.2...

asked Apr 2, 2021 in Android by p.gus109 New to the Community (2 points)

Please log in or register to answer this question.

1 Answer

0 votes
Are you using this guide?
answered Apr 3, 2021 by LeonidM Veteran of the Digi Community (4,457 points)
Basically, yes. I followed the guide to get everything installed but when I try to import a sample I get "Failed to download sample index...". So...

I then searched around for the git sources, which I found and downloaded them from there.
I ran the GPIO sample with no problem. The ADC is my second one to try and running into this problem...

I am able to reproduce Failed to download sample index...". I've notified the engineering. It should be fixed within a week or so
Thanks. Do you think that will fix the "No virtual method getADCChips()" issue?
The import works now, thanks, but the exception remains. Any Ideas?
So far no but I'm new to digi android APIs. The adc sample does not have any dependencies set in the gradle.build:

dependencies {

Should there be?
I read over the API docs but only mentions about having the adc permission set, which the sample's manifest does have...