Home/Support/Support Forum/Replace RCM3200 on a BL2600 board
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

Replace RCM3200 on a BL2600 board

0 votes
I have a BL2600 SBC with a bad RCM3200 core module. I ordered a stand alone RCM3200. Does anyone know what steps I need to take in order to use the new RCM3200 on the BL2600? I've tried writing a new ID block using the write_idblock_920_962.c file and followed the instructions, but it doesn't seem to be working. I am getting an out of data space error. Also, I don't know what size to make the user block. Hoping someone has done this before.
asked May 19 in Rabbit by mutantworm New to the Community (5 points)

Please log in or register to answer this question.

1 Answer

0 votes
Are you selecting the BL2600? Your board should be the following #define below if you are replacing it with an RCM3200. I'm not sure of your part# so I am assuming this is what you have.

//#define MYBOARD BL2600A // 44MHz RCM3200, 512K flash, 256K+512K SRAM, ethernet
answered May 19 by Campbell Veteran of the Digi Community (827 points)
Yes, I uncommented the BL2600A (that is indeed the board I am working with) in the writeidblock code file. I've tried several compiler configurations in DC 9.62 but I keep getting an error for not enough data space when I try to compile to the board. I also followed steps 13 through 16 in the comment sections of the writeidblock code file. The part number for the RCM3200 I am trying to use is 20-101-0520 if that helps.
You may need a development board to change the RCM3200 to BL2600.  Digi no longer sells dev boards for RCM3000 products.
Can you "Compile to .bin" from Dynamic C?  Do you have any macros configured in the project settings?  What happened to the original RCM3200 in the BL2600?  You may be able to program the RCM3200 disconnected from the BL2600 if you have a good power supply that you can connect to the Vcc and GND pins of the RCM3200.
It does not let me compile to bin file and I have no macros configured. All I get is "line    1 : ERROR DKCOMMON.LIB   : Out of constant data space."
Can you even compile a simple sample program?  If not, it sounds like your Dynamic C installation has been modified.  Maybe you should start with a fresh install of Dynamic C 9.62A and see if that resolves anything.
...