Home/Support/Support Forum/Xbee3 I2C ENODEV error

Xbee3 I2C ENODEV error

0 votes
Dear all,

I've been playing with my new XBees for few days, and I'm enjoying them a lot :)

I'm now trying to deal with the I2C bus and with micropython.
I'm then facing some difficulties.

My configuration is the following :
- XB3-24 - Zigbee - With firmware 100D

- Coordinator linked to two end devices with the following :
- AP : 4
- BD : 115200
- CE : 0
- D1 : 6
- P1 : 6
- PS : 1

When I open the micropython terminal on one of my end devices, the I2C.scan method works well :

>>> from machine import I2C
>>> i2c = I2C(1)
>>> i2c.scan()
[25, 60, 119]

But when I try to exchange more in detail with one of the I2C device, it doesn't works :/

>>> i2c.readfrom_mem(0x77, 0xD0, 2)
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
OSError: [Errno 7019] ENODEV
>>>

I've been trying to format the flash (both with XCTU and with micro python) without any kind of success.

I'm sure that I'm doing something wrong, but what ? Can someone help me ?

Thanks,

C.
asked Aug 26 in MicroPython by lbdcdrc New to the Community (1 point)

Please log in or register to answer this question.

2 Answers

0 votes
Have you simply opened the file manager in XCTU and tried formatting the file system from there without having the Terminal open or connected?
answered Aug 26 by mvut Veteran of the Digi Community (14,666 points)
0 votes
Yes I did :/
I tried with only the file manager (with and without having discovered the module) and with micro python.
answered Aug 26 by lbdcdrc New to the Community (1 point)
...