Home/Support/Support Forum/RCM3700 ethernet and RS232 not working
Welcome to Digi Forum, where you can ask questions and receive answers from other members of the community.

RCM3700 ethernet and RS232 not working

0 votes
My PCB uses the RCM3700 for communication over ethernet with a Weintek display. I have assembled lots of these PCB's without problems. Now I have a board that does not work, ie no connection to the display. Since the ethernet port is on the RCM3700, I replaced it. The PCB still does not work. The same PCB also supports RS232 for another project, so I assumed this would work. Sadly, the RCM3700 also does not work over RS232. Has someone experienced the same problem ? Please advice
asked Mar 1 in Rabbit by Verberk BVBA New to the Community (1 point)

Please log in or register to answer this question.

1 Answer

–1 vote
It sounds like a defective or damaged board. It might have been covered under warranty from Digi, but probably not if you replaced a component.

Be careful with how you handle the hardware to avoid ESD potentially damaging components on the board.
answered Mar 2 by TomCollins Veteran of the Digi Community (2,303 points)
I replaced the complete RCM3700 without success. Strange that also the RS232 is not working.
Can you test the RCM3700 in a Digi International development board?  Or can you test it by replacing the RCM3700 in a known-good, working version of your PCB?  It's not clear to me whether this is a problem with the RCM3700 or your PCB.
...