Wince image created with the BSP 3.5.1 sources is not able to detect the Wi-Fi adapter on the CCWi-i.MX53.

Problem:
The wince image created with the BSP 3.5.1 sources and installed QFE's_after April 2013 is not able to detect the Wi-Fi adapter on the CCWi-i.MX53.
Upon building the wince image using the default templates with the BSP 3.5.1 sources for CCWi-i.MX53, when the image gets uploaded to the module and checks the Wi-Fi status, this image is not able to detect the Wi-Fi adapter.
The boot log information is displayed below:

[CCWMXWifi]: Loading Wireless Driver Version 3.2.9c ... Failed.

Solution:
New release Patch is found at the following location on Digi's websitee:
Wireless Patch

Release Notes:
Fixes Wireless driver fails to load.
Update process for 3.2.12.0d release:
-------------------------------------
- Dll update:
  In the 'dll' folder from this zip, 
  choose '\QFE_AfterApril2013\CCWMXWIFI.dll' file if you have installed QFEs after April 2013,
  or choose '\QFE_BeforeApril2013\CCWMXWIFI.dll' file if your QFEs are older than that.
  Copy that file to '_TARGETPLATROOT\Files' folder in your PC.

- Firmware update:
  Replace _PLATFORMROOT\common\src\soc\COMMON_DIGI\DRIVERS\Redpine folder in your PC with the '\firmware\Redpine' folder from this zip.
- Rebuild your BSP and subprojects or sysgen the project.
- On reboot check that the wireless driver reports 3.2.12.0d version






 
Last updated: Aug 23, 2017

Filed Under

Embedded

Recently Viewed Articles

No recently viewed articles
Contact a Digi expert and get started today! Contact Us