Support / Knowledge Base / DigiESP for Digi embedded Linux does not start under Ubuntu/Kubuntu 14 or will fail to start after u

DigiESP for Digi embedded Linux does not start under Ubuntu/Kubuntu 14 or will fail to start after upgrade to Kubuntu 14

Using Ubuntu/Kubuntu 14 or after upgrade to version 14 or above user may experience following problem starting Digi ESP for Digi embedded Linux:  After an upgrade to Linux the IDE would start but would quickly shutdown the program.
Explanation:
Ubuntu version to 14.04 is not compatible with Eclipse version DigiESP uses. User can install updates and security patches for Ubuntu/Kubuntu but should not upgrade Ubuntu version in general and in particular to anything 14.x and up.
Details:
Digi Embedded Linux 5.7 (DEL-5.7) toolchain and Eclipse ESP was tested with Ubuntu 10.04.1 as provided on the DEL-5.7 Live DVD.
Digi Embedded Linux 5.9 (DEL-5.9) toolchain and Eclipse ESP was tested with Ubuntu 12.04 as provided on the DEL-5.9 Live DVD.
typically DEL-5.7 is also working fine on a Ubuntu 12.04 Linux development host system.
User should avoid installing updates which could move to different host development toolchain (gcc, make, ..) or different Java versions which could prevent Eclipse ESP to work correctly.
Getting the toolchain running on any other Linux distributions or version compared to the ones delivered on the Live DVD = installation DVD is not supported by Digi.
 
Last updated: Aug 23, 2017

Filed Under

Embedded

Recently Viewed Articles

No recently viewed articles
Contact a Digi expert and get started today! Contact Us